<!DOCTYPE html>
<html>
<head>
<title>Editorial: Cape Chamber honors members, celebrates milestone (2/2/17) | Southeast Missourian newspaper, Cape Girardeau, MO</title>

<meta name="viewport" content="width=device-width, initial-scale=1">
<meta property="fb:app_id" content="799085026788661">
<meta name="twitter:card" content="summary" />
<meta name="twitter:image" content="http://www.semissourian.com/images/nameplate-sharing-square.jpg" />
<meta name="twitter:site" content="@semissourian" />
<meta name="twitter:title" content="Cape Chamber honors members, celebrates milestone" />
<meta name="twitter:description" content="Not only did the Cape Girardeau Area Chamber of Commerce celebrate current community members and businesses who have made a difference in the community, but it also marked a major milestone, the..." />
<meta name="twitter:url" content="http://www.semissourian.com/story/2382371.html" />
<meta property="og:title" content="Cape Chamber honors members, celebrates milestone" />
<meta property="og:type" content="article" />
<meta property="og:description" content="Not only did the Cape Girardeau Area Chamber of Commerce celebrate current community members and businesses who have made a difference in the community, but it also marked a major milestone, the 100th anniversary of the chamber's official start, at its annual dinner on Friday..." />
<meta property="og:url" content="http://www.semissourian.com/story/2382371.html" />
<meta property="og:site_name" content="seMissourian.com" />
<meta property="article:published_time" content="2017-02-02T00:00-0600" />
<meta property="article:modified_time" content="2017-02-01T14:05-0600" />
<meta property="og:image" content="http://www.semissourian.com/images/nameplate-sharing.jpg" />
<link rel="canonical" href="http://www.semissourian.com/story/2382371.html">

<script src="/includes/global/external/jquery/jquery-1.12.4.min.js"></script>
<link rel="StyleSheet" href="/includes/v20170126/local/always/always.css" type="text/css">
<script src="/includes/v20170126/local/always/always.js"></script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u) {
    e.async = 1;
    e.src = u;
    f.parentNode.insertBefore(e, f);
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/rustcommunications-network/loader.js');
</script>
<script>
 // Load GPT
 var googletag = googletag || {};
 googletag.cmd = googletag.cmd || [];
 (function(){
   var gads = document.createElement('script');
   gads.async = true;
   var useSSL = 'https:' == document.location.protocol;
   gads.src = (useSSL ? 'https:' : 'http:') +
       '//www.googletagservices.com/tag/js/gpt.js';
   var node = document.getElementsByTagName('script')[0];
   node.parentNode.insertBefore(gads, node);
   })();
</script>
<script type="text/javascript">
googletag.cmd.push(function() {
   googletag.pubads().setTargeting("reg","N");
   googletag.pubads().setTargeting("sub","N");
});
</script>


<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-4243601-47', 'auto');
  var custom = {};
  custom.dimension1 = 'Opinion - Editorial';

  ga('send', 'pageview', custom);
  setTimeout("ga('send', 'event', 'Time', '30 sec')", 30000);
</script>

</head>

<body class="layout-one-column no-widgets module-story story-layout-default user-mode">

<div id="canvas">



<div class="popup leftrailmenu" data-pop-mode="leftrail" id="popupmenu" style="display:none;">
<div class="popupmenu_close menucloser">Close</div>
<div class="wrapper">
<nav id="popupmenuwrapper">
<ul><li><a href="/">Home</a></li>
<li><a href="/news">News</a></li>
<li><a href="http://www.semoball.com/">Sports</a></li>
<li><a href="/business">Business</a></li>
<li><a href="/features">Community</a></li>
<li><a href="/records/obituaries">Obituaries</a></li>
<li><a href="/records">Records</a></li>
<li class="active"><a href="/opinion">Opinion</a></li>
<li><a href="http://www.semoevents.com/">Events</a></li>
<li><a href="/submitted">Your Stories</a></li>
<li><a href="/multimedia">Photos & Video</a></li>
<li><a href="/blogs">Blogs</a></li>
<li><a href="/today">Today's Headlines</a></li>
<li><a href="/weather">Weather</a></li>
<li><a href="http://www.semohousehunter.com/">Homes</a></li>
<li><a href="http://southeastmissourian.thejobnetwork.com/">Jobs</a></li>
<li><a href="http://www.semomarketplace.com">Marketplace</a></li>
<li><a href="http://local.semissourian.com/">SemoSearch</a></li>
<li><a href="/classifieds">Classifieds</a></li>
</ul>

</nav>
<nav id="popupmenushortcuts">
<ul><li><a href="/contactus">Contact Us</a></li>
<li><a href="/customercare">Customer Service</a></li>
<li><a href="http://southeastmissourian.mo.newsmemory.com/">Online Reader</a></li>
<li><a href="/weeklyads">Weekly Circulars</a></li>
<li><a href="http://www.rustmedia.com">rustmedia</a></li>
<li><a href="http://www.rustcommunications.com/">Rust Communications</a></li>
<li><a href="/help/partners">Media Partners</a></li>
<li><a href="/siteindex">Site Index</a></li>
</ul>

</nav>
</div>
</div><!--/popupmenu-->

<div class="popup leftrailmenu" data-pop-mode="leftrail" id="searchmenu" style="display:none;">
<div class="searchmenu_close menucloser">Close</div>
<div class="wrapper">

<form id="searchform" method="get" action="/scripts/search/primary.php">
<div id="searchbox">
<input type="text" style="width:90%;" placeholder="Keywords" maxlength="50" value="" name="query">
<input type="hidden" name="source" value="quick">
<input type="submit" value="Search">
</div>
<div id="searchoptions">
<label><input type="radio" name="s" value="stories" checked="checked">Stories</label>
<label><input type="radio" name="s" value="blogs">Blogs</label>
<label><input type="radio" name="s" value="comments">Comments</label>
<label><input type="radio" name="s" value="photos">Photos</label>
<label><input type="radio" name="s" value="events">Events</label>
<label><input type="radio" name="s" value="classifieds">Classifieds</label>
<label><input type="radio" name="s" value="ownlocal">SemoSearch</label>
<label><input type="radio" name="s" value="realestate">Real Estate</label>
<label><input type="radio" name="s" value="cse">Everything</label>
<label><input type="radio" name="s" value="newsarchive">Archive since 1918</label>
</div>
</form>

</div>
</div><!--/searchmenu-->

<div class="popup leftrailmenu" data-pop-mode="leftrail" id="submitmenu" style="display:none;">
<div class="submitmenu_close menucloser">Close</div>
<div class="wrapper">
<b>Submit:</b>
<ul>
<li><a href="/submitstory">Story or photos</a></li>
<li><a href="/submitletter">Letter to the Editor</a></li>
<li><a href="/submitpaidletter">Paid Election Letter</a></li>
<li><a href="/submitspeakout">Speak Out comment</a></li>
<li><a href="/submitevent">Event</a></li>
<li><a href="/submitwedding">Wedding</a></li>
<li><a href="/submitengagement">Engagement</a></li>
<li><a href="/submitanniversary">Anniversary</a></li>
<li><a href="/submitbirth">Birth</a></li>
<li><a href="/scripts/classifieds/post.php">Classified ad</a></li>
</ul>

</div>
</div><!--/submitmenu-->


<div id="stickyheader" style="display:none;">
<div class="menulauncher">
<div class="popupmenu_open"><img src="http://www.semissourian.com/images/icons/menu-white.png" alt="*">Menu</div>
<div class="searchmenu_open">Search</div>
<div class="submitmenu_open">Submit</div>
</div>

<div class="nameplate">
<a href="/"><img src="http://www.semissourian.com/images/nameplate-wide.png" alt="*"></a>
</div>

</div><!--/stickyheader-->

<header id="Top">

<div class="firstline">
<div class="menulauncher">
<div class="popupmenu_open"><img src="http://www.semissourian.com/images/icons/menu-white.png" alt="*">Menu</div>
<div class="searchmenu_open">Search</div>
<div class="submitmenu_open">Submit</div>
<noscript><a href="/siteindex">Index</a></noscript>
</div>

<div class="userline"><ul><li><a href="/scripts/user/login.php" rel="nofollow">Login</a></li><li><a href="/scripts/user/register.php" rel="nofollow">Register</a></li><li><a href="/scripts/user/access.php" rel="nofollow">Subscribe</a></li></ul></div>
</div><!--/firstline-->

<div class="masthead">

<div class="nameplate">
<a href="/"><img src="http://www.semissourian.com/images/nameplate-grey.png" style="width:100%;max-width:600px;" alt="Southeast Missourian"></a>
</div>

<div class="extramenu">
<ul><li><a href="/">Home</a></li>
<li><a href="/news">News</a></li>
<li><a href="http://www.semoball.com/">Sports</a></li>
<li><a href="http://www.semoevents.com/">Events</a></li>
<li><a href="/features">Community</a></li>
<li><a href="/records">Records</a></li>
<li><a href="/records/obituaries">Obituaries</a></li>
<li class="active"><a href="/opinion">Opinion</a></li>
<li><a href="/classifieds">Classifieds</a></li>
<li><a href="http://local.semissourian.com">SemoSearch</a></li>
</ul>

</div>

</div><!--/masthead-->

</header>
<center><div id="dfp_unit_SEM_Leaderboard_Opinion" class="dfp-unit dfp-unit-leaderboard" data-unit="SEM_Leaderboard_Opinion" data-adclass="leaderboard"></div></center>
<center><div id="dfp_unit_SEM_Rectangle_Opinion_small" class="dfp-unit dfp-unit-rectangle" data-unit="SEM_Rectangle_Opinion" data-adclass="rectangle" data-screensize="small"></div></center>


<main><div class="wrapper">
<section class="zone2">





<div class="content">



<div class="storycanvas">
<div class="toolbar">
<ul>
<li><a href="#" onClick="window.print();">Print</a></li>
<li><a href="http://www.semissourian.com/scripts/form/sendlink.php?g=S2382371">Email link</a></li>
<li><a href="http://www.semissourian.com/scripts/form/feedback.php?g=S2382371">Contact editor</a></li>
<li><a href="http://www.semissourian.com/scripts/form/factcheck.php?g=S2382371">Report error</a></li>
<li><a href="#Respond">Post comment</a></li>


<li>Share:
<a href="http://facebook.com/sharer.php?u=http%3A%2F%2Fwww.semissourian.com%2Fstory%2F2382371.html&amp;t=Cape+Chamber+honors+members%2C+celebrates+milestone" target="_blank"><img src="/images/icons/social16/facebook.gif" width="16" height="16" title="Facebook" alt="Share on Facebook" class="sharer"></a>
<a href="http://twitter.com/home?status=Cape+Chamber+honors+members%2C+celebrates+milestone%20http%3A%2F%2Fwww.semissourian.com%2Fstory%2F2382371.html" target="_blank"><img src="/images/icons/social16/twitter.gif" width="16" height="16" title="Twitter" alt="Share on Twitter" class="sharer"></a>
<a href="http://pinterest.com/pin/create/link/?url=http%3A%2F%2Fwww.semissourian.com%2Fstory%2F2382371.html&amp;description=Cape+Chamber+honors+members%2C+celebrates+milestone" target="_blank"><img src="/images/icons/social16/pinterest.gif" width="16" height="16" title="Pinterest" alt="Share on Pinterest" class="sharer"></a>
</li>
</ul>
</div>

<div class="story" data-storyid="2382371">
<div class="kicker">Editorial</div>
<h1>Cape Chamber honors members, celebrates milestone</h1>

<div class="section group">

<div class="col span_8_of_12 first">
<section class="zone2">
<div class="content">

<div class="pubdate">Thursday, February  2, 2017</div>

<div class="text">
<p>Not only did the Cape Girardeau Area Chamber of Commerce celebrate current community members and businesses who have made a difference in the community, but it also marked a major milestone, the 100th anniversary of the chamber's official start, at its annual dinner on Friday.</p>
<p>"May we remain strong, viable, vibrant, responsive and effective," chamber president and CEO <a href="http://www.semissourian.com/story/2381220.html">John Mehner said</a>. "For the next 100 years and more."</p>
<p>The annual banquet was held at the Show Me Center with several individuals and businesses receiving recognition in front of a crowd that surpassed 800 people.</p>
<p>Charles L. Drury, a founder of Drury Hotels, was bestowed the Rush H. Limbaugh Award, and the entire Drury family was recognized for their impact.</p>
<p>"This extraordinary family has been so instrumental in enhancing the quality of life in Cape Girardeau and in many other places," David Limbaugh said. "I love how the Drurys have lived out their belief in traditional values and remained closely knit as an extended family, even as they separated some of their business operations. They were enormously successful together and they have all prospered in their various enterprises -- and through the generations."</p>
<p>Jim Limbaugh talked about the family's education, which came from "core family values, a relentless work ethic, a strict adherence to quality, integrity and perhaps most of all a devotion to their church."</p>
<p>Small Business of the Year was a tie between Begley, Young, Unterreiner & White LLC and Bennett Family Dentistry.</p>
<p>Cape Girardeau Convention and Visitors Bureau executive director Brenda Newbern was named Ambassador of the Year.</p>
<p>Mehner was recognized as a recent recipient of the Leadership Missouri Graduate Lifetime Achievement Award from the Missouri Chamber of Commerce and Industry.</p>
<p>Congratulations to all those recognized. We wish you the best and we wish the chamber good fortune in its next 100 years.</p>
</div><!--/text-->

</div><!--/content-->

<div class="toolbar-bottom"><div class="toolbar">
<ul>
<li><a href="#" onClick="window.print();">Print</a></li>
<li><a href="http://www.semissourian.com/scripts/form/sendlink.php?g=S2382371">Email link</a></li>
<li><a href="http://www.semissourian.com/scripts/form/feedback.php?g=S2382371">Contact editor</a></li>
<li><a href="http://www.semissourian.com/scripts/form/factcheck.php?g=S2382371">Report error</a></li>
<li><a href="#Respond">Post comment</a></li>


<li>Share:
<a href="http://facebook.com/sharer.php?u=http%3A%2F%2Fwww.semissourian.com%2Fstory%2F2382371.html&amp;t=Cape+Chamber+honors+members%2C+celebrates+milestone" target="_blank"><img src="/images/icons/social16/facebook.gif" width="16" height="16" title="Facebook" alt="Share on Facebook" class="sharer"></a>
<a href="http://twitter.com/home?status=Cape+Chamber+honors+members%2C+celebrates+milestone%20http%3A%2F%2Fwww.semissourian.com%2Fstory%2F2382371.html" target="_blank"><img src="/images/icons/social16/twitter.gif" width="16" height="16" title="Twitter" alt="Share on Twitter" class="sharer"></a>
<a href="http://pinterest.com/pin/create/link/?url=http%3A%2F%2Fwww.semissourian.com%2Fstory%2F2382371.html&amp;description=Cape+Chamber+honors+members%2C+celebrates+milestone" target="_blank"><img src="/images/icons/social16/pinterest.gif" width="16" height="16" title="Pinterest" alt="Share on Pinterest" class="sharer"></a>
</li>
</ul>
</div></div>

<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script>

</section>
</div>

<div class="col span_4_of_12 second">
<section class="zone3">



<center><div id="dfp_unit_SEM_Rectangle_Opinion_medium-large" class="dfp-unit dfp-unit-rectangle" data-unit="SEM_Rectangle_Opinion" data-adclass="rectangle" data-screensize="medium-large"></div></center><center><div id="dfp_unit_SEM_Rectangle2_Other_medium-large" class="dfp-unit dfp-unit-rectangle" data-unit="SEM_Rectangle2_Other" data-adclass="rectangle" data-screensize="medium-large"></div></center>








</section>
</div>

</div><!--/section-->
</div><!--/story-->

</div><!--/storycanvas-->




<div class="section group"><div class="col span_8_of_12 first">

<div class="respond"><div class="wt" id="Respond">Respond to this story</div><p><em>Posting a comment requires free registration:</em></p>
<ul class="bulleted hyperlinks">
<li>If you already have an account, <a href="http://www.semissourian.com/scripts/user/login.php?refer=http://www.semissourian.com/story/2382371.html">follow this link to login</a></li>
<li>Otherwise, <a href="http://www.semissourian.com/scripts/user/register.php?refer=http://www.semissourian.com/story/2382371.html">follow this link to register</a></li>
</ul>


</div>
</div><div class="col span_4_of_12 second">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- semissourian.com rectangle -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-5826862484148534"
     data-ad-slot="6590287616"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>

</div></div>

<div class="storywidgets storywidgets-below">
<article class="w ww-O w-popular wc-default wb-N wa-A" id="w16795"><div class="win wp-O" data-widgetid="16795"><div class="wt wt-Y">Most read stories</div><div class="winc wf-big" id="winc16795"><ul class="lists-stories lists-stories-bulleted-headline bulleted"><li><a href="http://www.semissourian.com/story/2381218.html" class="l"><span class="headline a">Additional charges filed against Jackson man accused of child abuse; woman also charged</span>  <span class="pubdate">(1/29/17)</span></a></li><li><a href="http://www.semissourian.com/story/2381221.html" class="l"><span class="headline a">Number of children requiring foster care jumps in region</span>  <span class="pubdate">(1/29/17)</span><span class="commentscount">3</span></a></li><li><a href="http://www.semissourian.com/story/2381544.html" class="l"><span class="headline a">Cape Muslim doctor: Travel ban unjust, unhelpful</span>  <span class="pubdate">(1/31/17)</span><span class="commentscount">32</span></a></li><li><a href="http://www.semissourian.com/story/2380852.html" class="l"><span class="headline a">'Remember that time ...': Marble Hill sisters reminisce on 100 years of memories</span>  <span class="pubdate">(1/29/17)</span><span class="commentscount">4</span></a></li><li><a href="http://www.semissourian.com/story/2380673.html" class="l"><span class="headline a">Meadow Heights considers four-day school week</span>  <span class="pubdate">(1/27/17)</span><span class="commentscount">10</span></a></li><li><a href="http://www.semissourian.com/story/2379848.html" class="l"><span class="headline a">Stepfather choked girl, 6, during homework argument, police say</span>  <span class="pubdate">(1/25/17)</span><span class="commentscount">1</span></a></li><li><a href="http://www.semissourian.com/story/2379837.html" class="l"><span class="headline a">Drury buying 12.5 acres near I-55 from city for $1M</span>  <span class="pubdate">(1/25/17)</span><span class="commentscount">3</span></a></li><li><a href="http://www.semissourian.com/story/2380655.html" class="l"><span class="headline a">Tip of man's finger bitten off during fight, police say</span>  <span class="pubdate">(1/27/17)</span><span class="commentscount">1</span></a></li><li><a href="http://www.semissourian.com/story/2378919.html" class="l"><span class="headline a">A message from heaven</span>  <span class="pubdate">(1/23/17)</span></a></li><li><a href="http://www.semissourian.com/story/2380331.html" class="l"><span class="headline a">All about the trout: Season begins at Jackson's Rotary Lake on Feb. 1</span>  <span class="pubdate">(1/26/17)</span><span class="commentscount">1</span></a></li></ul></div></div></article>

<article class="w ww-T w-mixer wc-default wb-N wa-A" id="w16869"><div class="win wp-O" data-widgetid="16869"><div class="wt wt-Y">More to explore</div><div class="winc wf-big" id="winc16869"><ul class="lists-stories-bulleted-headline bulleted"><li><a href="http://www.semissourian.com/story/2382435.html" class="l"><span class="headline a">Downtown merchants shrug off construction project</span>  <span class="pubdate">(2/2/17)</span></a></li><li><a href="http://www.semissourian.com/story/2382427.html" class="l"><span class="headline a">Cape increases number of officers trained to respond to mental-illness situations</span>  <span class="pubdate">(2/2/17)</span></a></li><li><a href="http://www.semissourian.com/story/2382425.html" class="l"><span class="headline a">Fruitland meat processor, sewer district strike deal to solve each other's problems</span>  <span class="pubdate">(2/2/17)</span></a></li><li><a href="http://www.semissourian.com/story/2382423.html" class="l"><span class="headline a">State Supreme Court rejects legal challenge to Cape nuisance law</span>  <span class="pubdate">(2/2/17)</span></a></li><li><a href="http://www.semissourian.com/story/2382444.html" class="l"><span class="headline a">World of knowledge: Cultural Exchange Network volunteers give demonstrations to Oran students</span>  <span class="pubdate">(2/2/17)</span></a></li><li><a href="http://www.semissourian.com/gallery/captured101" class="l"><span class="headline a"><span class="kind">Gallery</span>: Captured on Film #101</span>  <span class="pubdate">(2/2/17)</span></a></li><li><a href="http://www.semissourian.com/story/2382448.html" class="l"><span class="headline a">Doctor who was Cape's first neurosurgeon dies at 81</span>  <span class="pubdate">(2/2/17)</span></a></li><li><a href="http://www.semissourian.com/story/2382426.html" class="l"><span class="headline a">Southeast student punched while walking near campus</span>  <span class="pubdate">(2/2/17)</span></a></li><li><a href="http://www.semissourian.com/story/2382416.html" class="l"><span class="headline a">Police: Sikeston woman used stun gun on children</span>  <span class="pubdate">(2/2/17)</span></a></li><li><a href="http://www.semissourian.com/story/2382417.html" class="l"><span class="headline a">Scott County explores consolidating 911 systems</span>  <span class="pubdate">(2/2/17)</span></a></li><li><a href="http://www.semissourian.com/story/2382428.html" class="l"><span class="headline a">McCaskill: Dems boycotted Cabinet vote because new information surfaced</span>  <span class="pubdate">(2/2/17)</span></a></li><li><a href="http://www.semissourian.com/story/2382477.html" class="l"><span class="headline a">Cape Girardeau County Commission agenda 2/2/17</span>  <span class="pubdate">(2/2/17)</span></a></li><li><a href="http://www.semissourian.com/story/2382497.html" class="l"><span class="headline a">Beyonce announces she's pregnant with twins on Instagram</span>  <span class="pubdate">(2/2/17)</span></a></li><li><a href="http://www.semissourian.com/story/2382445.html" class="l"><span class="headline a">Smoke-ring launcher</span>  <span class="pubdate">(2/2/17)</span></a></li><li><a href="http://www.semissourian.com/story/2382443.html" class="l"><span class="headline a">Learning briefs 2/2/2017</span>  <span class="pubdate">(2/2/17)</span></a></li><li><a href="http://www.semissourian.com/story/2381939.html" class="l"><span class="headline a">Jackson municipal inmates soon will be housed at county jail</span>  <span class="pubdate">(2/1/17)</span></a></li><li><a href="http://www.semissourian.com/story/2381946.html" class="l"><span class="headline a">By popular demand: Ranken College in Perryville, Southeast add manufacturing-based education</span>  <span class="pubdate">(2/1/17)</span></a></li><li><a href="http://www.semissourian.com/gallery/29302" class="l"><span class="headline a"><span class="kind">Gallery</span>: Human Rights Protest at SEMO</span>  <span class="pubdate">(2/1/17)</span></a></li><li><a href="http://www.semissourian.com/gallery/29299" class="l"><span class="headline a"><span class="kind">Gallery</span>: Exchange students visit Oran Elementary School</span>  <span class="pubdate">(2/1/17)</span></a></li><li><a href="http://www.semissourian.com/story/2381965.html" class="l"><span class="headline a">Irritating fumes evacuate Fountainbleau Lodge; no injuries reported</span>  <span class="pubdate">(2/1/17)</span></a></li><li><a href="http://www.semissourian.com/blogs/2000/entry/68198" class="l"><span class="headline a"><span class="kind">Blog</span>: Tax Fraud Protection</span>  <span class="pubdate">(2/1/17)</span></a></li><li><a href="http://www.semissourian.com/story/2381981.html" class="l"><span class="headline a">Judy Garland's remains moved from NY to LA</span>  <span class="pubdate">(2/1/17)</span></a></li><li><a href="http://www.semissourian.com/story/2381901.html" class="l"><span class="headline a">Troopers: Perryville man possessed child porn</span>  <span class="pubdate">(2/1/17)</span></a></li><li><a href="http://www.semissourian.com/story/2381922.html" class="l"><span class="headline a">State's supreme court upholds local judge's ruling in sodomy case</span>  <span class="pubdate">(2/1/17)</span></a></li><li><a href="http://www.semissourian.com/story/2381932.html" class="l"><span class="headline a">Cape officer uses physical force to control fleeing suspect</span>  <span class="pubdate">(2/1/17)</span></a></li><li><a href="http://www.semissourian.com/story/2381982.html" class="l"><span class="headline a">Oprah Winfrey to be 'special contributor' to '60 Minutes'</span>  <span class="pubdate">(2/1/17)</span></a></li><li><a href="http://www.semissourian.com/blogs/flynch/entry/67785" class="l"><span class="headline a"><span class="kind">Blog</span>: SEMO Coach Ron Shumate's first year</span>  <span class="pubdate">(2/1/17)</span></a></li><li><a href="http://www.semissourian.com/story/2381871.html" class="l"><span class="headline a">Cape Council seeks strategic input, planning public meetings in all 6 wards</span>  <span class="pubdate">(1/31/17)</span></a></li><li><a href="http://www.semissourian.com/story/2381548.html" class="l"><span class="headline a">Southeast president tries to reassure students about travel ban</span>  <span class="pubdate">(1/31/17)</span></a></li><li><a href="http://www.semissourian.com/story/2381544.html" class="l"><span class="headline a">Cape Muslim doctor: Travel ban unjust, unhelpful</span>  <span class="pubdate">(1/31/17)</span></a></li><li><a href="http://www.semissourian.com/blogs/fromthemorgue/entry/68092" class="l"><span class="headline a"><span class="kind">Blog</span>: Charles W. Stehr</span>  <span class="pubdate">(1/31/17)</span></a></li><li><a href="http://www.semissourian.com/blogs/flynch/entry/67822" class="l"><span class="headline a"><span class="kind">Blog</span>: Neighborly coaches: Arnzen and Milligan</span>  <span class="pubdate">(1/30/17)</span></a></li><li><a href="http://www.semissourian.com/blogs/1452/entry/68173" class="l"><span class="headline a"><span class="kind">Blog</span>: One More Time, Please Pay Attention</span>  <span class="pubdate">(1/28/17)</span></a></li></ul></div></div></article>
</div>


</div>
</section>
</div></main>

<footer>
<div class="wrapper">

<ul>
<li>Sections
<ul>
<li><a href="/news">News</a></li>
<li><a href="/sports">Sports</a></li>
<li><a href="/events">Events</a></li>
<li><a href="/features">Community</a></li>
<li><a href="/opinion">Opinion</a></li>
<li><a href="/records/obituaries">Obituaries</a></li>
<li><a href="/records">Records</a></li>
<li><a href="/blogs">Blogs</a></li>
</ul></li>
<li>Shopping
<ul>
<li><a href="/classifieds">Classifieds</a></li>
<li><a href="http://www.semohousehunter.com/">Homes</a></li>
<li><a href="http://www.semomarketplace.com/">Marketplace</a>
<li><a href="http://local.semissourian.com/">SemoSearch</a>
<li><a href="/jobs">Jobs</a></li>
<li><a href="/weeklyads">Weekly Circulars</a></li>
</ul></li>
<li>seMissourian.com
<ul>
<li><a href="/search/">Search</a></li>
<li><a href="/search/browse">News archives</a></li>
<li><a href="/forums">Forums</a>
<li><a href="/submitted">Your Stories</a>
<li><a href="/contactus">Contact Us</a></li>
<li><a href="/help/legal">Terms of Service</a></li>
<li><a href="/help/partners">Media Partners</a>
</ul></li>
<li>Services
<ul>
<li><a href="/access">Subscribe/register</a></li>
<li><a href="/contests">Contests</a></li>
<li><a href="/quiz/movietrivia">Movie Trivia</a></li>
<li><a href="/onlinereader">Online Reader</a></li>
<li><a href="/textalerts">Text Alerts</a></li>
<li><a href="/mail">Mailing lists</a></li>
<li><a href="http://www.facebook.com/semissourian">Facebook</a></li>
<li><a href="http://twitter.com/semissourian">Twitter</a></li>
<li><a href="http://www.rustmedia.com/">rustmedia</a></li>
</ul></li>
<li>Submit
<ul>
<li><a href="/submitwedding">Wedding</a></li>
<li><a href="/submitengagement">Engagement</a></li>
<li><a href="/submitanniversary">Anniversary</a></li>
<li><a href="/submitletter">Letter to the Editor</a></li>
<li><a href="/submitpaidletter">Paid Election Letter</a></li>
<li><a href="/submitspeakout">Speak Out</a></li>
<li><a href="/submitevent">Event</a></li>
<li><a href="/submitstory">Story / Photo</a></li>
<li><a href="/scripts/classifieds/post.php">Classified ad</a></li>
</ul></li>
<li>Shortcuts
<ul>
<li><a href="/opinion/speakout">Speak Out</a></li>
<li><a href="/opinion/cartoons">Editorial cartoons</a></li>
<li><a href="/today">All headlines</a></li>
<li><a href="/weather">Weather</a></li>
<li><a href="/multimedia">Photo galleries</a></li>
<li><a href="/multimedia/video">Video</a></li>
<li><a href="/siteindex">Site Index</a></li>
</ul></li>
</ul>

<div class="copyright"><a href="/help/legal/">&copy; 2017 Southeast Missourian</a> &middot; <a href="/contactus">Cape Girardeau, Missouri</a></div>
<div class="sitemap"><a href="/siteindex">Site Index</a> &middot; <a href="#Top">Back to top</a></div>

</div>
<div id="dfp_unit_SEM_OutOfPage" class="dfp-unit dfp-unit-outofpage" data-unit="SEM_OutOfPage" data-adclass="outofpage" data-outofpage="yes"></div>
</footer>


</div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>

</body>
</html>